Problem with Password Protected Excel file

I am trying to use the Write Range activity to write a datatable into a password protected Excel file.

If I use the Application Integration Activity (with Excel App scope) to write into a password protected cell range, I get the “Range does not exist” error message.
I have already tried inputting the “Password” and the “Edit Password” options here. That does not help.

If I use the System Integration Activity, it disturbs the formatting of the Excel Template - especially cell borders.

Is this a bug or a known issue? How do we get around this?

EDIT: Certain ranges within a particular sheet in my Excel are password protected - not the entire file itself. I want the robot to be able to make edits in these protected ranges.


While taking Excel Application Scope if you pass password in Properties it will perfectly work.

Find attached implemented (20.0 KB)

1 Like

Hi @Rahul_S

Thank you for your response. Unfortunately, it doesn’t solve my problem.

I must make a clarification here. My entire excel file isn’t password protected - just select fields in a worksheet are locked for editing. I want the robot to be able to input something into these sheets.

Please refer the below post.

1 Like

The activity called Protect Unprotect, developed by Balamurali as a part of the BalaReva excel activites solved my problem here.

Thank you @balupad14 for developing this package! This is a real service to the community.

Thank you @Vivek_Arunagiri for pointing me there :slight_smile:


Thank you @Vivek_Arunagiri and @anupamck,

You can get this package in UiPath Go also.


1 Like


Is it possible for you to send sample excel file which you are talking about?

So, we can get exact idea what you are trying to do

Hello @Rahul_S,

In the below link , you can get the sample project.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.