Problem with ocr

So I have problems with get ocr text (“Value cannot be null. Parameter name: source”). It should read numbers from a website, but sometimes it have problems with numbers of 1 digit like 8, 0, 5. I use Google Cloud Vision OCR.

Hi @Condrat_Claudiu ,

Have you tried other orcr?

You can put get ocr in try catch and another get text ocr in catch block so here if Google ocr get failed it will try Microsoft ocr.

Not the best approach but you can try.


Hi Claudiu,

I had a similar issue with numbers like 3,5,8. Sometimes it mixed the number 8 with 3 and it is dangerous in a production environment. I know that using Microsoft Azure OCR solved this issue :slight_smile:

Good luck!

Hi @Condrat_Claudiu,

Trying other OCR types should help here. Not every OCR works in every situation. Its kind of experience gained by hit and trial or reference to some matrix(already tried and tested by someone) on this:)

I am also attaching OCR accuracy matrix that was shared in uipath devcon, might be helpful for you.