Problem when copying formula in excel cell

I am copying a formula of logic type in excel to bring values ​​from one sheet to another with uipath. When applying the formula manually it works well for me, however when I use automation it generates the following error:

You need to replace all semicolons ; with commas ,
Don’t worry it will look correct in the Excel file.

E.g. if I want the formula =SUM(A2;B2)+10,5 in Excel I need to convert it to "=SUM(A2,B2)+10.5" in UiPath.

Thank you very much. I made the change as it tells me but it still does not work. The formula is this

=SI.ERROR(INDICE(F_VENTAS!$A$1:$G$132;COINCIDIR(J2;F_VENTAS!$E$1:$E$132;0);COINCIDIR($K$1;F_VENTAS!$A$1:$G$1;0));"")

What do I need to change to make it work?

Sorry, I believe you need to translate all the function names to English also.

Test with this translator:

Thank you very much. I made the change but I still get the same error. What other solution can I apply?

I can’t see the last thing I post

You said that you could enter the formula manually, is that correct? If so, please create an excel file with the formula and then use Read Cell Formula to read it. How does that formula look like?

Yes, If when I copy the formula manually it does not generate errors .

=SI.ERROR(INDICE(F_VENTAS!$A$1:$G$132;COINCIDIR(J2;F_VENTAS!$E$1:$E$132;0);COINCIDIR($K$1;F_VENTAS!$A$1:$G$1;0));"")

Save the Excel file after you have edited manually. Then create a workflow to read the formula from the Excel file:

image

In the Output panel you will find the formula as it should be formatted in UiPath. You can right-click it, copy and then paste into the Write Cell activity.

image

In this case strformula is a variable or a property? You can show the properties of “Read Excel formula” and “write line”

It’s a string variable.

image

image

Also change the Cell and SheetName accordingly.

Thank you very much. I can see the formula in uipath

I’m going to use it and see if it works

Good luck! I see that it’s writing the formula without the equal sign so you will need to add that also.

At the end of your formula, you have two double quotes. Double quotes in UiPath need to be escaped. E.g. to get =IFERROR(ab, "") you need to write it as "=IFERROR(ab, """")" in UiPath.

image

image

it worked very well. Thank you very much my friend.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.