PDF activities taking forever to run


Hello. I have a robot that works daily for months now. It downloads a certain PDF from my company website and extracts some information needed. This PDF has not changed format, size, font, anything. It is the same but, ever since I last uploaded UiPath, all the PDF related activities (like Get PDF Page Count and Read PDF Text) are taking forever to run. A single page takes over a minute to be read. My robot, that used to take 10 minutes to run full, are taking over 2 days to read every page (several PDFs are downloaded from the website, all of them with this issue).
I created an empty new project to test those activities. Recently installed, everything up to date, and still taking all this time. I tested with another similar in size PDF my coworker borrowed me and it worked out fine, super fast! But the thing is, my PDF is not corrupted or anything. It didnt change. Everything is updated. What should I do?


Welcome to the community

Are those scanned pdf?

The test you made is also on same type of pdf?

Are there any bookmarks or size differences?

Are you using ocr activities?


Hello Anil, thank you! No, they are not scanned, doesnt have bookmarks or anything. Size hasnt changed at all over the last few months (and its also smaller than other pdfs I tested that worked fine, it has 800kb with 149 pages). Also not using ocr. When I change the path of the pdf in the activity to other similar looking pdf it works fine so I dont think I have the wrong configuration. This other pdf I tested is not downloaded from the same website, it is from my coworker. I wish I could upload the pdf in here but im a new user so I cant :frowning: