Path too long - Chrome Extension

Hello all!

I’m trying to use Google Chrome extension for my RPA developmnet and I’m getting the following error:

invalid path ‘\?\C:\Users*username*\AppData\Local\Google\Chrome\User Data\Default\Extensions\gbkeegbaiigmenfmjfclcdgdpimamgkj\128.2226.2237_0\scripts\lib\qowt\third_party\when\node_modules\promises-aplus-tests\node_modules\sinon\test\sinon\util\fake_server_with_clock_test.js’ (path too long)

I have the same problem. Do you have this problem since the last update too?

Yes, after the last update. I’ve checked and you can solve this by obviously reducing path length… but in this case it’s google chrome default path.

I had the same problem after the last update and it took me more than a whole day to fix it. :sweat: I eventually fixed it but I am not a 100% sure what I did and in what order. But what you can try is the following:

  1. Remove the extensions from all of the browsers you’re interacting with
  2. Remove the file where the path name points to
  3. Uninstall Uipath
  4. Remove everything left on your computer that has anything to do with UiPath. You might want to look for this in AppData and Program Files. (except for your actual developed robots. You might want to make a backup though, just in case.)
  5. Download and Install the last version of UiPath again
  6. Install the browser extensions again
  7. Try to run a bot again, if you get the same error message:
  8. Move the file where the error message points to a few folders up.
  9. Repeat step 3 - 6.

Hope it helps!