Package userpackage1.0.4 does not support any target frameworks

Guys I’m also getting this error. I have created my own user defined packaged which I’m not trying to use in a Library Project. When I go to install my user defined packages, I’m getting the same error NU1202: Package userpackage 1.0.4 is not compatible with net461 (.NETFramework,Version=v4.6.1). Package userpackage1.0.4 does not support any target frameworks.

I have also uninstalled STUDIO and reinstalled but it didn’t fix this issue!


cc: @loginerror

Hi @kdawg

Could you provide more detail about your Studio version and the activity packages used in your projects?

Hi @loginerror,

My Studio version is Studio 2019.10.4 Enterprise Trial License.

And the local activity packages I created are all on the same studio version. I have updates all their dependencies before publishing but now when I try to install the packages that I published in a new Library Project, I get this error.

For example, one of my activities is a background process that I published locally:

After I publish this and try to install it locally in my Library Project, this error occurs. This happens with all the other local packages I have published as well. Everytime I try to install it in my Library project, I get the same error

We got the same error 2019.4.4 and published using enterprise license. @loginerror @kdawg
Any luck?

Hi @vikram.v

Welcome to our UiPath Forum! :slight_smile:

The issue is fixed in the 2019.10 release. To get it working, you would need to:


I am using Studio 2020.4.3. And I am also getting same error while installing custom activity.

Hi @mitesh

Could you republish your custom activity from the new Studio version and try again?
The fixes are only applied on the new version if you did that.

1 Like

Hi @loginerror,
Thanks for you input. Issue resolved. As you suggested, I had to republish custom activity after updating dependencies used in same custom activity.
I am getting another error , please take a look at below page:

1 Like