Package installation failure

Hi,
I have formatted the C drive and then re-installed the same studio version, when I opened up the process I found that all activities are unresolved. I copied all the packages to my local packages folder and tried to repair the dependencies but issue still persists

image

.Net Framework version is 4.6.2
Studio version is 2018.4.5

appreciate your support

@Ahmad_Mariam
Welcome to the forum

open the dependency manager (Design-Manage Packages) and check under the setting if additional sources are configured (user defined package sources) or maybe to add

Hi @ppr,
I already added the package sources under the User defined packages sources, all packages are copied there.

image

@Ahmad_Mariam
Perfect. So in such a case a general approach is to notice all dependencies, remove most of them and adding it again. This allows to identify the package that breaks

@Ahmad_Mariam

Welcome to our UIPath Community.

Right click on those packages and select repair dependency and check it once.

Thanks @ppr,
will try that

Hi @lakshman,
i did that many times, i removed all packages and added only one with all its dependencies but it still appear in red. i tried package with no dependencies and still issue persists

@Ahmad_Mariam

You are using old version of UIPath studio. I guess the packages you installed here may not support those versions. Could you please install latest version of studio and then try once.