Orchestrator returns Error 429 Too many requests when im on the Enterprise plan

When i send more than 50 documents for Document Understanding I receive this error. I am not on the community plan

Hi @DannyVelkov ,

Could you let us know what was the Endpoint used ?

For what reason?

Hi @DannyVelkov

Is the end point you are using from the same orchestrator? Or is it from a different orchestrator which is on the community plan?

And what kind of license you have for AI center


No, it’s the skill from the orchestrator with the Enterprise plan.
I can disclose only this part of the endpoint:
The licence is UiPath-Flex Plan Bundle

@DannyVelkov ,

Could you let us know what are the set of activities involving the Document Understanding Part (Digitize Document, Classification and Data Extraction Scope) that you have been using for this task ?

Check the properties and if a config file is used check if there are community end points used there which in turn it is being used by these activities, You would need to change it there by appending the below to the endpoints :


Let us know if this doesn’t help.

It does not help. I tried with 50 invoices and the same error appeared.
Here is the URL I used:

Here are the settings for the activity:

@DannyVelkov ,

Could you let us know what was the OCR used ? If UiPath OCR is used, what was the endpoint provided to it ?

I am using Microsoft OCR. Maybe it’s because it’s a public endpoint this error occurs? But I can no longer access studio on Enterprise account to get the ML skill options and select them

@DannyVelkov ,

Could you Debug the workflow from the Studio, We could maybe able to understand which Activity is throwing out this error Or Could you maybe pinpoint from the Orchestrator Logs as to where the Error is happening ?

No need to append the line mentioned above for ML Skills.

If Intelligent Keyword Classifier is being used, then check the endpoint provided to it as well.

Let us know if you need further help in debugging.

I started the debugging and this is the activity that threw the error:

The endpoint is:

I realized my mistake. The API key that was being used was for an account with Community Edition. Now it works properly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.