Orchestrator CE Issue - Failed to install Package

Hello everyone :slight_smile:

I’m facing a issue with Orchestrator CE. I can’t run any jobs from there.

Screenshot:
image

I’m behind a proxy and I already tried:

  • Changed the Nuget.config (adding https_proxy config)
  • Changed the UiPath.Service.Host.exe.config (adding proxy config)
  • Changed the UiPath.Executor.exe.config (adding proxy config)

I’m able to connect to Orchestrator CE without issues and able to publish my packages. Also the robot is showing as Connected. But I can’t run any jobs from Orchestrator CE.

I’m not able to download the package directly from UiRobot tray neither. I click but nothing happens.
image

Uipath Version: Studio 2018.2.6

Anyone have faced this before? Any tips to solve this issue?

Thanks in advance :slight_smile: You guys rock!

Regards,

2 Likes

Please check the robot credentials as well.

1 Like

Hi @Lucas.Pimenta

Just a hint, maybe it helps. Could you check if you have all the dependencies available locally for the robot?

1 Like

Please check the robot credentials as well.

Already checked that. Everything is fine. I’m able to connect to Orchestrator and get assets from there as well. :frowning:

Hi @Lucas.Pimenta

Just a hint, maybe it helps. Could you check if you have all the dependencies available locally for the robot?

Done, but without success :confused:

Maybe it’s a bug? I notice that on .nuget folder, the package are not being created when I start the Job on Orchestrator. Also, if I put the package on that folder manually, when I run it from Orchestrator or try to download through the UiRobot tray the package just get deleted.

Hello,
Could you confirm that the Nuget.config file that you edited is the one from:
“C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet” ?
Also UiRobotSvc should be restarted after modification.
Thanks,
Cosmin

1 Like

Nope. It was not.

Just changed this file but without success too (I restarted the UiRobot Service after modification)

Here’s the line I added:

< config>
    < add key="http_proxy" value="[PROXYADDRESS]:8080" />
  < /config>

Still facing the same error.

@EDIT

I noticed that even on local publishing, I’m not able to update and run my published packages

image

I keep clicking on the button but nothing happens and I just can’t run it locally too. Also, the .nuget folder keep creating the folders from the package but not the package itself

Hi,
Can you please try to put the robot in user mode and are if it works to download the package?

1- stop uirobot.service
2. close tray/studio
3. cmd > sc delete UiRobotSvc
4. Start tray > UiPath.Agent
then you verify that it uiservice.host is running as a process, not as a service (you can are this in the windows process explorer)

Try to download the package now.

To put it back in service mode you close everything and type uirobot.exe --restart in your installation path, în cmd.

5 Likes

Hi,
I just checked the same scenario, and it is working on our side, so i think that are some small configuration problems on your side.
Do you have Studio Community edition or MSI?
If you have Comunity, then you should add the proxy settings to Nuget.config from folder “C:\Users\xxxxx\AppData\Roaming\NuGet”
If you have MSI, you should add the proxy settings to Nuget.config from folder “C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet”
If this does not work, then i think there are some wrong proxy configuration. I tried both scenarios (Community and MSI) with 18.2.6 and is working for me

Thanks.

2 Likes

It worked like a charm :smiley: :smiley:

I don’t know why, but all the depencies was not downloaded on .nuget folder. It was empty. Now with your procedure all dependencies packages got downloaded and now I’m able to run the Jobs through the Orchestrator and also locally.

You guys are the best :slight_smile:

Thank you very much.

Regards,

1 Like

Yes, but now you are no longer running robot as a service, meaning that when you logout the robot becomes unavailable. This is ok if you are using it as development/attended but you cannot use it as unattended.
The problem basically is that the local system account doesn’t have one of the following:
-proxy rights
-antivirus rights
-some local policy rights
This needs to be investigated and fixed if you wish to run robot as a service and be able to access Orchestrator.

2 Likes

This is weird. I restarted my machine and back to Service Mode (UiRobot Service has been restarted) and now it’s running without any problems. I’m able to publish packages, update them and run Jobs through Orchestrator without any issues. Also I’m able to update and run the packages through the agent (UiRobot tray) as well.

1 Like

That is weird. Maybe the nuget proxy settings did not apply till after the update.

2 Likes

Yeah, maybe.

Anyway I’ll investigate further to see if I can find the issue. For now everything is running fine :slight_smile:

Thank you for the support!

Regards,

2 Likes