Omnipage CSDK is missing

Hello everyone,

I wanted to try out OmniPage OCR but am getting an error:

UiPath.SmartData.Digitization.Tokenization.TokenizationException: TestZusprache.PNG —> RemoteException wrapping System.Exception: Error performing OCR: Could not load file or assembly ‘Nuance.OmniPage.CSDK.Objects, Version=, Culture=neutral, PublicKeyToken=d277acbc760e5eaf’ or one of its dependencies. The system cannot find the file specified.

It seems that OmniPage CSDK is missing on my machine. How can I install it to get OmniPage OCR working?


Welcome back to UiPath forum

Go to design tab → manage packages → All Packages → search as


We can install with this package

Please make sure the Official Feed is activated in your package manager

For that in manage packages windows go to settings and check all the feeds and then try searching for the package

Cheers @jreddy

I installed and reinstalled it several times already and result is still the same.

1 Like

You can see the error is related to the dependencies of that package. You need to have the dependencies installed too in order to use Omni Page OCR. Check that and install the needed ones

Please install the Omnipage OCR Bundles pkg from official feed.

Geetishree Rao

No worries
In All Packages → search as UiPath.OmniPage.Bundle and install it


Cheers @jreddy

@jreddy I have the same issue and just like you, I have tried all that was suggested here and still I have the same issue. Do you still have the issue or have you resolved it? If you have, please share how you did.

Update: @jreddy , I solved this issue by using UiPath Document OCR engine instead of Omni Page OCR engine. I still have to do some more research, but at this time, I feel Omnipage ocr is meant for images only, whereas UiPath Document OCR engine is for PDF documents. The name says it all. Hope this helps, in case you are still looking for a solution.


I have just downgraded the Omnipage OCR Activities package version 1.6.1 -preview and its working

Vivek Gupta