Old Issue but Adobe Reader DC 18 and using Find Element within PDF document not working ... weird resolution

In the Level 1 - Foundation Training - 2018.3 Lesson 10 session it talks about the PDF features of uiPath. First thing I hit was not being able to use Find Element using Adobe Reader DC 19 and even the last version of 18. Adobe Acrobat XI just worked … no issues … but you really can’t goto a customer saying they have to use an out-of-support PDF reader.

I tried everything on this forum I found to make Find Element work within a PDF document in Adobe Reader DC 18. Nothing worked. But … this does work for me oddly every time:

  • You start the Adobe Reader DC 18 with the document open
  • Immediate go into a simple sequence that does three attach windows which basically do this click sequence => Edit -> Preferences -> Cancel … yes, I know doing the Cancel is weird …
  • Now Find Element will work in the PDF document fine … don’t ask me why but it works for me EVERYTIME. Then, go into another sequence or whatever that does the PDF text scrapping using Anchor Base with Find Element and Get Text blahblahblah.

Yeah, it’s really really weird and I can’t explain it but it works.

Hi @soneill437

Could you post a zip of a sample project? Or at least some screenshots? :slight_smile: