Office 365 Scope doesn't authenticate properly in Windows compatibility

In Windows Legacy, I have my scope configured this way:

In Windows compatibility, I have it configured this way:

Identical configuration.

When I run it in Windows Legacy, the authentication (interactive token) prompt correctly appears within the UiPath process. But when I run the Windows compatibility version, it launches the authentication prompt in my browser (Chrome). This doesn’t work, as the application isn’t seen correctly so it gives me this message:


I am using the same version of UiPath.MicrosoftOffice365.Activities in both projects (1.11.1). I tried 1.14.1 in the Windows compatibility version, and the result was the same.

If I first run it in Windows Legacy so the authentication token is correctly created on my machine, then run it in Windows compatibility, it bypasses the authentication step and is able to get emails.

Although I can’t get the same version, I tried upgrading UiPath.Mail.Activities to 1.15.2 (highest version available for Windows) along with Office 365 1.11.1 and when running I now get this error:

Microsoft Office 365 Scope: Method not found: ‘Void Microsoft.Graph.GraphServiceClient…ctor(System.Net.Http.HttpClient)’.

Tried Mail 1.15.2 with Office 365 1.14.1 and didn’t get an error, but the authentication prompt still appears in Chrome instead of the UiPath process.

@loginerror @AlexCrijman @Akshay_Agnihotri this is a big problem, who can help me?

We found out from support that this is expected behavior, the authentication source changed. It doesn’t open in the Robot process any more, it opens in the browser. We did add the URL to our Azure application and it solved the redirect error.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.