Notepad selector

Hi , I am getting this error.

How to add notepad in selectors. Thanks


try to use dynamic selectors for the title.

1 Like

It is not working

Hi @Shruti_Dhond,

Use a wildcard for the selector’s title as below. :slightly_smiling_face:

<wnd app='notepad.exe' cls='Notepad' title='*- Notepad' />




Make selector dynamic by using wild card entries. Here Title attribute should be like this.


Make the that change and then try.

1 Like

How to add selector?

1 Like

What are the basic settings we can do for selectors? Do we need to add them each time? I am getting same kind of selector errors while executing web recording programs. Please guide.

1 Like

Hi @Shruti_Dhond

This would help you for sure

and the reason why the error occurred for you is when you are trying to open the notepad before this attach window activity, the title attribute will be like this
title = ‘Untitled - Notepad’ in the previous activity of attach window
and as you were trying to type into a element having title like
title = ‘New Text Documnet (2) - Notepad’, it becomes a mismatch…right
so to make sure that we should be able to identify the element of any titled notepad, we have use wildcard symbol * in the title attribute so that it would consider any notepad window with any title attribute and for more info on how to add selectors kindly have a view on the above threads buddy
Kindly have a look at this and let know if you face any issues

@Palaniyappan Thank you very much.

I have done settings as per you suggested like this.

But still I am getting this message.

Please guide.