Not able to see the component Submitted

Hello team,

I had submitted my snippet on UiPath Go yesterday.
I was not able to preview the component with the ‘Preview’ button provided before submission.
Also, I am not able to see the snippet page now when i click on the Component Name in ‘My Uploads’ Section.
Attached is the message displayed after clicking.

Please look.
Also, if anyone knows please tag the correct team.
Thanks in advance

Preview does not work, you have to wait until your component passes the validations.

It used to work for my previous uploads in UiPath Go!
I used to check it before it passed validations.
I was able to see at least how it looks before it gets published.

It never worked for me when I tried to upload components.
Are you uploading a different type of component than before?

No. It is the Same type of component as before. (A snippet)

I guess the page page redirection is not working.
when i click on Component name it is saying, ‘You are already logged in’
If i am going somewhere wrong it should have displayed a message same as you said below