Not able to Publish package in UIPath - entry point could not be found

Hi , I am trying to publish project and getting following error .

“Could not publish project entry point could not be found” .

tried multiple options
1.Updated all Activities.
2. tried to UN-install and install

Please suggest solution


Welcome to the UIpath Community.

Are you trying to publish Main.xaml file of the process or any other file are you publishing it.


Hi lakshman,

Thanks for your reply its Main.xaml


1 Like


Could you please try to publish some other project and check once.

Hi @Yogi

Is the main.xaml file marked as the main file in your solution where the execution starts?

Also make sure there are no run time or debug errors


Thanks all for providing valuable input , it seems in my project.json my main.xaml file name changed to main(Autosaved).xaml , and that was causing this issue.


The issue is possible due to cross package reference in project.json or mail.xaml (or other xaml) file. One way to solve it is to create another new project and copy the activities in the old project to the new project.

If you get this error, right click on the “main” activity and make sure it is set to main (also it should appear bold)

cross Link:

Hi @Yogi,

Try the following:

  1. Delete .Json file (be sure the main activity is close)
  2. Open the Main file
  3. Update or re-install unresolved packages if need it
  4. Save changes
  5. Try to publish your project again.

Hope that works.