None of the overload groups have all their required/optional activity arguments configured in any add data row

When trying to add rows to a data table I get this error (it worked fine earlier in the project), when trying to put data in the array, or row options after using the editor and clicking OK it does not save the content. I tried to regress the UiPath system activities pack to 22.10.4 and back to 22.10.3 and that did not work either.


It’s necessary to set data (argument) at either ArrayRow property or DataRow property. Can you try this?



Either give a datarow or arrayrow as input…if you want to create an empty row then in arrayrow you can give {} like this which adds an empty datarow to the given datatable

Hope this helps


Hi @Nathan_Betters1 ,

This is also observed at times, which might be considered as a Bug. More specifically we get the error when adding the values from the Activity’s Front UI Display itself.

However, if you try to open the ArrayRow/DataRow property from the Properties Panel in the right and edit/add the data, the values should be added to the property field and it should not give out an error.

Let us know if you have tried this out as well.

Format is not the problem, it won’t save. Once I hit the ok button the entry didappears.

Hi @Nathan_Betters1

This should be fixed in the latest System 23.4.1-preview. Could you please give it a try and let us know if you are still experiencing this issue?