Need help with FTP

ftp
studio

#1

Hi, I am having some issues with FTP upload. The connection is a success, the directory on the server exists, the folder of on the server is 777, but I am still having issues uploading. I can remove folders on the server with the same connection, but not upload. For the local folder I have “C:\Users\Gary\Documents\PTC\Labels195248.xlsx” and for remote path “/var/www/vhosts/ttt”. What am I doing wrong ? Thanks


#2

Hi @Gary_K,
Can you please try with the following format:
"ftp://www.yourwebsitename.com/yourfilename.fileextension"
Note: You can replace the website name with IP address if you have an IP Address

Regards,
Jiban


#3

Hi @jibanjyoti, the file is on the local machine that needs to transferred to the server. Is this for “ftp://www.yourwebsitename.com/yourfilename.fileextension” the local path or the server path ?

Thanks
Gary


#4

I gave this for FTP transactions. Give a try for your FTP Server.


#5

Hi @jibanjyoti . I have a similar problem. I am trying to download a file from the following url which I have FTP access to http://www.cloudsafrica.com/images/maths.jpg. If I enter this address as the remote path for the ftp.download activity, nothing happens. However, I am confident that the login credentials are correct because, if I enter incorrect user name, I receive an error message. When I run the process with the correct username, there is no error message but also, no download. Your help would be greatly appreciated.


#6

Hi @tobar, It seems like an URL to the image.
If you have an FTP configured for you then you can try that with FTP Download activity.


#7

Thank you for replying so quickly @jibanjyoti. I have now also tried the remote path as “ftp://www.cloudsafrica.com/images/maths.jpg” but it is still not working. Also, when I check whether the file exists using UiPath it returns false. However, I can see the file on the server at this location. Do you have any further suggestions?


#8

May be some network related restrictions. I would like to suggest you, just to check with your IT team for any security restrictions.


#9

This really doesn’t look like an FTP path and it downloads fine with HTTP Get.

Are you sure you need FTP for this?


#10

Hi @jibanjyoti. I have made progress and am able to create new directories. However on uploading a file to the directory I get a message as per this screen capture:

I looked into this and found the following: https://stackoverflow.com/questions/45606287/ftpclient-timed-out-trying-to-read-data-from-the-socket-stream

Is it possible to change the timeout settings for ftp activities?


#11

Thank you @andrzej.kniola for your suggestion. I got that to work for the download file. However, to upload a file to the web server, am I right that this can only be done using FTP or can I use Http client with “put”? Also, where would I enter the security login details and port etc? For the login details I have tried “simple authentication” but this is having the following result:

"

405 Method Not Allowed

Method Not Allowed

The requested method GET is not allowed for the URL /sandbox/2/.

Additionally, a 405 Method Not Allowed error was encountered while trying to use an ErrorDocument to handle the request.


Apache Server at www.url.com Port 80 ".

With post, I get the following, but the file is not being uploaded:

"

Index of /sandbox/2

Index of /sandbox/2

Apache Server at www.mywebsite.com Port 80 </html"

@jibanjyoti . Do you have any suggestions?


#12

Check with network team for some clarifications on the PORTs that you are using.