My.Computer Method not found

Hello All,

Require some guidance on the below issue.

BOT is running fine with the older system activity (19.0)

When we have updated the system activity to higher version(21.0). I am getting the error like method is not compile in Invoke code( code in

Can you share your screenshot and error message? Too little information is posted in your message.

Hi Shubin,

Thanks for the response.

Kindly have look at the attached image.

When we have updated the system package to higher version like 21.1.0 or above. We are getting this error.

If the system package is in 19.1.0 like that BOT is running fine.

Hi Kabeer
What is inside your invoke method? Can you run it on another computer with the latest version of system activity?

 The issue is possible due to your computer.


Ok let me try with other machine and let you know the outcome.

The purpose of the VB code is to check the notepad file is exists or not.

If yes then it will check whether it’s contain the particular string in the notepad file.

Another option is to use UiPath

> File Exists

activity as shown below, to check if a file exists.



We can also use Microsoft.VisualBasic.Devices.Computer instance instead of My.Computer as the following. (It’s exactly same.)

(new Microsoft.VisualBasic.Devices.Computer).FileSystem.FileExists("c:\temp\test.txt")

(new Microsoft.VisualBasic.Devices.Computer).Name

Or we can use System.IO.File.Exists method, too , if we want to check file exists.


Hi Shubin,

Yeah I am aware of that . Since we have used the code already I tried to figure it out in the same method.

Thanks Yoichi,

I will try this and let you know whether it’s worked fine or not.


I am getting this error.


It seems matter of InvokeCode activity. If possible, can you try to downgrade System.Activities package to 20.10.x?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.