Move File Activity Not working while running bot from orchestrator

Hi Team,

I am using move file activity to move file to shared drive path, while running the same bot through uipath studio it is perfectly moving the file to required shared drive path.
When running through prod orchestrator the file is not moving to shared drive path, also i have different path of shared drive for prod system for that bot is moving file smoothly when running through orchestrator but when i am using test system shared drive path i am facing issue in moving file.
I am unable to get logs for move file activity also why it is not moving the file.

Hi @saleem-shaikh !

The first thing that comes to my mind is to check the variables you put for move file, would you mind telling us more about it ?
Example: if you used Path.GetFullPath():

  • in PROD then Path.GetFullPath starts from C:\Users\<username>\.nuget\packages\<name_of_package>\<package_version>\lib\net45
  • in DEV then it’s where you have your original Main.xaml Studio so somewhere like C:\Users\<user_name>\Documents\UiPath

Also, the fact that there was no error returned might be linked with a try-catch: do you use try-catch around move file activities ?

Does the Windows account the bot is running unattended under have permissions to the path?

Are you using full paths, or mapped paths? It’s generally a bad idea to use mapped paths like X:\myfolder\somefile - if X:\ is \\someserver\sharedfolder then you should use \\someserver\sharedfolder\myfolder\somefile

Even i too facing when i run the bot through orchestrator its not moving files but its moving when i run it through studio any solution.