Modern Design: Use Excel File loads very slow

Hello everybody,

I am reaching out to the community since I am stuck with this problem:

I got several projects which have loading issues when using the ‘Use Excel File’ scope. It takes about 1,5 Minutes to open the Excel Files each time. I don’t understand what is taking Studio so long to open the files.

In rare cases it will only take seconds, but mostly it is 1,5 minutes.

The problems occur on Version 2021.4 and 2022.x (I would need to check the exact version, but it is not the newest release).

Does anybody have an idea what is going on and how to solve this?

1 Like


What is the formatting options you have chosen? can you try with different options and see if it helps?

Hello @nino.dy
try to use Workbook activity instead of excel application scope.
Otherwise Set show windows as false. I may reduce time.

Default formatting is used. Sometimes we use Read Only.

1 Like

I actually didn’t try this one yet, because in the documentation it writes that it only hides the window but still opens it.

Also I try to avoid Workbook activities because of performance issues with larger files.

The classic Excel Application Scope does work normally and fast, but misses some features I am using with the moden design.

1 Like

I am running into a similar issue.
When I load Excel, it has one add-in: the UiPath Excel add-in.
Excel now loads very slowly.
Removing the add-in results in Excel loading quickly again.
However, reinstalling the add-in leads to slower load time again.
Like yourself, I would rather use Modern Experience for my automation vs classic.
The time for running 7 queue items suddenly went up from 1 minute to over 7 minutes because of this issue.

While I opened Excel again, i got this error about “OLE Action”. I closed the dialog box and it is working now again.
Fix Excel is waiting for another application to complete an OLE action (


In project setting > activities settings, you can change the time to wait for excel to start. In my configuration it was in both cases 20 seconds.

Now I have modified it and set 0 seconds and it works faster.

I hope it helps you.