Message: Object reference not set to an instance of an object with REFramework


I am seeing this Object reference not set to an instance of an object in my workflow that uses RE Framework. While I know what this error means, I am unable to pinpoint the part of my workflow that is causing this error. I am therefore seeking your help in correcting my mistake.

The Error occurs when executing Framework/GetTransactionData.xaml

The Error message I am seeing


Source: Log message  (Get transaction data error)

Message: Object reference not set to an instance of an object.

Exception Type: System.NullReferenceException

RemoteException wrapping System.NullReferenceException: Object reference not set to an instance of an object. 
   at lambda_method(Closure , ActivityContext )
   at Microsoft.VisualBasic.Activities.VisualBasicValue`1.Execute(CodeActivityContext context)
   at System.Activities.CodeActivity`1.InternalExecuteInResolutionContext(CodeActivityContext context)
   at System.Activities.Runtime.ActivityExecutor.ExecuteInResolutionContext[T](ActivityInstance parentInstance, Activity`1 expressionActivity)
   at System.Activities.InArgument`1.TryPopulateValue(LocationEnvironment targetEnvironment, ActivityInstance activityInstance, ActivityExecutor executor)
   at System.Activities.RuntimeArgument.TryPopulateValue(LocationEnvironment targetEnvironment, ActivityInstance targetActivityInstance, ActivityExecutor executor, Object argumentValueOverride, Location resultLocation, Boolean skipFastPath)
   at System.Activities.ActivityInstance.InternalTryPopulateArgumentValueOrScheduleExpression(RuntimeArgument argument, Int32 nextArgumentIndex, ActivityExecutor executor, IDictionary`2 argumentValueOverrides, Location resultLocation, Boolean isDynamicUpdate)
   at System.Activities.ActivityInstance.ResolveArguments(ActivityExecutor executor, IDictionary`2 argumentValueOverrides, Location resultLocation, Int32 startIndex)
   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

You will need to create a queue called StockExchange in your Orchestrator to run this project.

Thanks a lot for your help. (1.0 MB)

1 Like

Debug and check where the error is coming @SRoy

First, Happy Birthday. I tried debugging and it looks like there is some issue with arguments and the Config variable. I tried my best but could not make any progress.

1 Like


I will check and revert back to you

As you can see, in_Config dictionary is empty hence exception.

On further investigation I found root cause in Init call. Try not to change these arguments of ReFramework. Check below.

1 Like

I have made the changes but it seems that Config is empty from the get go. The error still persists.

@KanadMehta I have made the necessary changes to the Arguments and also changed the Argument direction in the InitAllSettings out_Config to In/Out and it seems to work.