Maximum message size quota for incoming messages (65536) has been exceeded


I have an API call implemented.

If I have a smaller response, all works as expected.
If the response is bigger, I get the following error:

RemoteException wrapping System.InvalidOperationException: Could not invoke client method. —> RemoteException wrapping System.ServiceModel.CommunicationException: The maximum message size quota for incoming messages (65536) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element.

From the other threads, I have tried adding binding to UiRobot.exe.Config, with no luck.
The error message still says message size = (65536), while the binding I added should show the size to be (2147483647).

Could you please help! @loginerror @bcorrea @Palaniyappan

Thank you!


Hi @sumitd,

Please add binding maxBufferSize=“2147483647”

Omkar P


Hi @Reddy_Paluri - thank you very much! That worked like a charm - good learning!

EDIT: @Reddy_Paluri - sorry, this is not fixed yet. The issue still remains. There was some thing else going on with the webservice and the response was null. This fell in the small response category and the error didn’t show up. Webservice is up again and so is the error.

Also, it still shows 65536 and not the updated size.

1 Like

Hi @sumitd

What is your Studio version + versions of all dependencies used in your project?

Thanks for looking into this!

Studio: 2020.4.1


Can you please try downgrade version like webapi.activities 1.4.0

@Reddy_Paluri - I was on 1.4.0 earlier - same error. Thanks!

it is wcf or webapi?


 <binding name="wsBinding" maxReceivedMessageSize="2147483647" maxBufferPoolSize="2147483647" maxBufferSize="2147483647"  >
      <readerQuotas maxArrayLength="2147483647" maxStringContentLength="2147483647" />

@Reddy_Paluri - no luck. Just to be sure, I am updating UiRobot.exe.Config, correct?
Thank you!

did you restart the robot after making the change?

Yes, I did. Thanks @bcorrea

1 Like

Any other suggestions?

If that didnt work, then you may be modifying the wrong config file, whether you are testing this using the studio, robot, assistant etc…

@bcorrea - that is my guess too. I am modifying UiRobot.exe.Config. Should it be a different one?

Well, you never said where you are testing this, you are the one who can tell that…

Oh yes, I have been testing this at each step! As mentioned in the topic description and my previous replies, adding to UiRobot.exe.Config doesn’t work in this case.
What else can I try?

I’ve registered it as a bug for our team to investigate. I will update this topic when things are a bit more clear.

For now, it seems like the setting is redundant since 2019.4 and doesn’t do anything.

1 Like

Thank you @loginerror! Would you be able to provide any time estimates at this point? I am in the middle of a project and this is a blocker.
Also, I am reasonably sure there are other users as well who use API calls and will be facing this issue. Any alternate way they might be accomplishing this?
I am unable to split the call into multiple calls and therefore unable to reduce the response size.

Thank you @loginerror, @Reddy_Paluri and @bcorrea for looking in to this!