Continuming:Maximum message size quota for incoming messages (65536) has been exceeded

Hi Guys!
I have the same issue and the studio version is 2020.4.1
I want to know if this issue was repaired?
Or How I run the code like below to avoid this issue.
Dim binding As BasicHttpBinding = New BasicHttpBinding()
binding.MaxReceivedMessageSize = Int32.MaxValue
Dim client As WSElectronicOrder.WSElectronicOrderSoapClient =
New WSElectronicOrder. WSElectronicOrderSoapClient(
binding, New EndpointAddress(“http://localhost:8088/mockWSElectronicOrderSoap ”))

Dim request As GetOrderHistoryRequest = NewGetOrderHistoryRequest(“jlk”,“jlkj”,“20200614”,“jkjl”, “”)
response = client.GetOrderHistory(request)

BestRegards!

Continuing the discussion from Maximum message size quota for incoming messages (65536) has been exceeded

Donghai –

You need to generate your API from the WSDL for the service you are trying to contact. Then use that API to update the maximum message size and then make your call as shown in the code snippet. The key is to find the equivalent generated SoapClient in your API. The WSElectronicOrderSoapClient is part of the API generated from the web service’s WSDL that we were interacting with.

So replace WSElectronicOrder.WSElectronicOrderSoapClient and the other objects with the client and objects generated by your WSDL:

Dim client As WSElectronicOrder.WSElectronicOrderSoapClient =

New WSElectronicOrder. WSElectronicOrderSoapClient(

binding, New EndpointAddress(“http://localhost:8088/mockWSElectronicOrderSoap 4”))

Because I have a deep experience coding it was easier for me to just dump the code into an Invoke Code Activity which allows you to code directly in UI Path. But there is nothing about the code that could not be done using basic UIPath activities to create variables and call methods etc.

Eric

Hi Eric.
Thank you very much for your reply.
I got the right way to implement this by search .net soap from google.
Then I used in Invoke Code Activity, but I don’t set up the maxreceievesize parameter, and I have got the response 67MB, Now it worked.
Thanks again!
Best Regards!