Map Network Drive

How to Map a network drive in uipath?

1 Like

Ankeeta Priyam, what r u trying to do… Could you please show some more light on your question.
Mapping a drive is related to PC. your admin will help. what to do with UiPath ? how does it related.

This is what I have done.!

After running, network drive get created but the problem is that it shows disconnected.

image

There are multiple reasons for disconnection.some times you may not having proper rights on that specific drive what you are trying to connect.also there are 2 check boxes on the map drive wizard.make sure you enable 1st one to connect.
before going to create, please give a try in manually and check whether you are able to connect or not.

Hope my inputs are useful.

I have tried connecting it manually, it’s working that way. Also I have enabled the 1st check box.

Please include 2 more steps in your WF.

  1. Right click on the disconnected/ Newly created drive.
  2. select on connect on the menu.

Hope that works.

There is no connect option in the menu.

See your network admin… perhaps he may be helpful to verify your account access rights on active directory service.

If the problem is with my account access rights then it also should not have mapped when I did manually. I don’t think that’s the problem.

Did you get this to work? I’m actually working on this now and would like to see your example if you would share?

Thanks!

Hi!

The same thing happens to me, I can not connect to a network unit.

The unit is mapped but only connects manually.

Has anyone solved it?

Thank you

I’m actually sick today and not in the office we have been successful so if this can wait until Monday I will follow up.

Tell us your solution… Its already tuesday :stuck_out_tongue:

Sorry I didn’t get in yesterday. I just looked and we did remove this process so I’m going to work on this right now and see if it works still.
We ended up just giving all of our VM’s access to the network drives.

I used Power Shell to do this and it maps the drive out.
image

And the Type Argument is a String. And it maps my drive out. I hope this helps.

3 Likes

There seems to be only one way when you have to deal with secure credentials: Open a cmd box and type command and secure credentials into the command line.

If you want to use credentials, pass them along:
“net use Z: \xxxx01\xxx101 /user:username password”

IsScript should be ticked in properties.

Also helpful to disconnect mapped drives:
“net use Z: /delete /y”

2 Likes

I have used @Ibaibm approach and my powershell script as below:

bstr = [System.Runtime.InteropServices.Marshal]::SecureStringToBSTR(in_Password)
$PlainTextPassword = [System.Runtime.InteropServices.Marshal]::PtrToStringAuto(bstr) net use in_DriveLetter **in_SharedNetworkPath** /user:in_Username $PlainTextPassword”

where in_Username, in_Password, in_DriveLetter, in_SharedNetworkPath are the Powershell variable. Please refer attached screenshot