Macro error on .xlsm

I have macro enabled in my .xlsm workbook and still getting below error.



Can you please go to The Macro Settings once again and check.

Options>Trust Center> Trust Center Settings > Macro Settings


This should work!

I have same settings and I also tried to Enable Excel 4.0 checkbox checked. Same error getting all time.

Can you share the Macro file Formula.txt as a screenshot here?

Qty_On_Hand Formula.txt (353 Bytes)

Did you pass parameters like this?


I am first reading the file and that read range I put like this in parameter.
FYI- read is the Datatable for read range

you need to correct this as

Ok, I am reading an Excel by opening it. Any changes on that or it’s fine ? And after updating the formula I a getting same error.

that shouldn’t be an issue,
do one thing take your data in a normal xlsx file,
use Excel Application scope, read range and then invoke vba with your range.

Try that.

Ok, will try that and let you know. Can I use move file activity or Copy file with rename in xlsx ?

that might corrupt the file.

Can you try that manually first?

If that works then you can use Use the modern excel activities there you can save it as xlsx.


It copied into .xlsx but giving me this error.

What activity needs to use in excel modern ?

I manually created exl and still the same issue.
FYI- I am reading an excel without headers If I read it with headers It gives error of column name “A” already exist to data table.

Ok, I am reading an Excel by opening it. Any changes on that or it’s fine ?