Logs are not showing in Orchestrator

Logs are not showing in Orchestrator (Robots->Logs and Jobs->Logs).
I followed this article(No logs generated in Orchestrator) but still not working.It showing as “No data to show”.

Same here , followed the standard installation and configuration instructions and have deployed our bot to the Orchestrator and its working okay however there are no logs on the Orchestrator while on Bot machine there are logs being churned propperly …followed all the workaround provided in the forum and elsewhere to no avail , have also validated web.config settings etc but still no logs publishing/visible on the orchestrator

@Mihai_Dunareanu @ovi , Pls suggest a workaround on this thread. we’re using v2018.2

@Christopher_Arputhar , Were you able to resolve the logs issue pls? Let me know if you have workaround

No @PawanTyagi , Still I didn’t get any workaround for this issue.

Ok,Which version are you implementing please?, in my case I am implementing the enterprise trial of v2018.2.4

I am using 2018.2.3 and also trial of v2018.2.4 is another system. both are having same issue

waiting for more than 15 days. Please give us a solution.

Iam also facing the same issue.
Logs are not getting loaded.

Hi @Christopher_Arputhar Please follow the steps below and let me know if that fixes your issues:

  1. Open orchestrator web.config
  2. Search for “Robot.*” and change value of “writeTo” property to database.

Let me know if it helps.

1 Like

Hi, same issue after updating to 2018.3.1. Logs are stored in the database (uipath.dbo.logs table) but are not visible in Orchestrator. In web.config the “writeTo” property is set to “database,robotElasticBuffer” but in ElasticSearch the logs are missing. Before update everyting was normal: logs available on both sides.
Any idea from UiPath team?

Hello folks,
I have the same issue. Anyone solve this error ?
I make an upgrade from 2018.1.2 to 2018.4.3 adn no more logs. But they are still in SQL database.


Feel free to contact our technical support in case of specific issues with your Orchestrator installation.

Did anyone find or get a fix for this…? We have recently encountered this same issue. We recently upgraded Redis, so not sure if that is somehting in common with others that have encountered this issue (bug?)…
Log info is being written to SQL and also on the Automation Server AppData/%userid%/local/uipath folder.It just not longer is viewable in Orchestrator, so appears Orchestrator can no longer pull from SQL.

Just remove the two different entries/targets for ELK in the web.config and keep only one to solve the issues. Thanks

Hey Pawan,

How are you able to see your logs table in Microsoft SQL Server Mnaagement STudio?

I tried doing a Select * on the dbo.Logs table.

There are several databases but I logged in using the Connection String that had the User ID=uipath. Still I don’t see any results.

I think ELK was configured by default, however I thought logging would happen both in the Orchestrator SQL database and the ElasticSearch database? Why do I not see any results in the logs table?

Hello @Shawn_Ngoh ,

Are you able to slve this issue?


I did not but the issue is no longer relevant for me