JObject is not defined - System.Activities.InvalidWorkflowException

Hello guys!

I’m facing a strange problem here, and I need your help.

I published a library and after I created an example project which works with it. Both work perfectly, including the output of libraby activity.

My problem is in another project. It works with the published library as well, but when I try to run it… a kind of validation error occurs (it doesn’t even perform the first activity):

I think it happens due to Newtonsoft.Json dependence

They are not dark blue as the other project whick there is no error.

Can you help me please?

please check the project dependency for Newtonsoft.json is available or not

  • if no - please add the package to the project.

Hello GBK,

It seems it’s not available because its color is light blue instead of dark blue.

Project with error:

In the project which there is no error all of them are dark blue.

Do you know how to solve this?

Maybe I need to delete some temporary/cache file

Thanks

And one point to add here…

My co-worker was working with this Library as well. It was working as expect, but suddenly the same error happened.

We just uninstalled the library, closed the project, opened the project, and installed it again… and everything started to work perfectly as before.

I tried this in my project, but no success :frowning:

Pls check the netonesoft.json package (same version no) is available in your orchestrator library/package section… if not - pls update orchestrator with the current/latest version of netonesoft.json.
After that pls open MetabaseIntegration library --> do manage package and verify/update newtonsoft.json package --> publish and use the latest version of MetabaseIntegration library in your current project.

1 Like

So…

I added Newtonsoft.json dependence (lastest version 12.0.3) in the project and in the library.

Now, according to workflow tree… all Newtonsoft.json dependences resolve to version 12.0.3).

There are more Newtonsoft.json depences inside the tree, but I only printed those.

But the same error still continues :frowning:

Thanks

You should not mix version dependencies of same package, in your case, your library should also use 11.0.2

2 Likes

Thanks a lot Bruno and Girish.

It’s finally fixed now :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.