Issue with Data scraping and Data table

Hi,

I am trying to read a table from a website using “Data scraping” and storing it in a data table and deleting the first 2 rows in the data table. I am facing issues with the data table and choosing the column name while filtering the data table.

Step:1 scraping the table from the website. It works fine and below is the image that I get while trying to scrape the website.


The headers from the webpage are updated as rows and I can see new Column name as “Column-0” in the extract wizard.

Step-2 I try to write the data table into a worksheet but no headers are updated in the sheet. Only from Company name row, it is updated in the sheet.

Step-3 I trying to delete first 2 rows with “COMPANY NAME” in the first column but I am unable to use Select query with Datatable. I tried using “Column-1” but getting “column name not found” exception.

Can someone help me on deleting the first 2 rows?

Hello @Karthik111

You can use the filter data table activity to remove the two rows from the data table.

In the filter data table activity, set the filter type to “Remove” so that those rows will be removed.
For the column name provide “Column-0” and for the value provide “COMPANY NAME”

it will work for you

1 Like

Hi @Lahiru.Fernando

I tried using the below query - ExtractDataTable.Select("[Column-0] = ‘COMPANY NAME’") and getting error message as “Cannot find Column [Column-0]”.