Issue getting Double Click to work in a list in a DOS application

Our company has a DOS/COBOL program that we are looking to automate tasks in. I am running into a problem trying to double click a line item from a list.

The selector looks like this

If I do a Double Click activity on P1003 nothing happens if the text is not in the window.

If the text is in the window the Double Click activity works perfectly.

After some testing we found using the highlighter


The text we are trying to double click is being detected behind the scenes in the application. By accident we found that should the highlighted area of the text go over other text or another icon that text or icon will be double clicked not the intended text.

SimulateCLick and SendWindowsMessages do not work with this application and error out in UI Path.

I even tried a Get Focus and Double Click. The Set Focus will move the list and highlight P1003, but the Double Click activity for some reason double clicks the first item in the list.

I am at a loss as to what else to try.

Hi @steven.malone

Make sure the text is there on screen before you perform any click action, parallelly try with click text and click activity with making some changes in selector and make sure the selectors in double click doesn’t vary every time you scrap especially idx attribute.


Thank you for your help. I was able to get the double click to work using a combination of Set Focus, followed by a down arrow key, and then the Double Click. A tab command also worked but a Delay did not.

I am unfortunately running into a new issue where after the double click occurs and UI Path goes to move on to the next workflow I get an error

Execution error: file ‘X:\execute\cobol32\LBR\PANELS2.gnt’
error code: 114, pc=0, call=30, seg=0
114 Attempt to access item beyond bounds of memory (Signal 11)

Not sure how using UI path to automate the process is causing a memory error in the application. If I take out the double click activity the workflow of course doesn’t do what it is supposed to do but the memory error goes away. Odd.