Is it a Bug? Syntax error ')' Expected keep appearing

Hi, I encountered some unique problem which a syntax error “BC30198: ‘)’ expected” suddenly appeared.

I’m assigning value to argument in Invoke Workflow like above and this error suddenly appeared. I believe I write it right cause I always did like that.
and when I clear the value from it, the syntax error suddenly move on to the activity above it like this:

I tried to clear the value again and the error move again to above activity which is so weird.

Any Idea?

HI @ibnu.alem

Take the new activities and assign the values in that after assigning the values then remove the previous activities and this might sort the issue.

Regards

Hi @ibnu.alem ,
I think the type of argument is not match with value assigned
‘array of’ and ‘string’
let check it,
hope it help,

If I take new assign, and reassign it. The error just moving downward

Hi @ibnu.alem

Can you share the value in assign activity.

Regards

No.
The argument is string and what I assign is string.
the assign activity however is array variable and what I assign is array format.

the error appear to any expression

I see,
In your comment above, there are 2 assigned activities and only 1 error,
Please point out what are their differences
image

I think we have syntax error only
Regards,

Sure.


this is the argument.

and this is the value in assign activity to String Var.

This is why I think it’s a bug.

there’s no difference at all, since I just copy paste the activity.

like I recorded, the error just moving to another activity that have expression

What’s your current version?
Maybe it’s a bug
Let’s try close studio then open it again
hope it help,

Hi @ibnu.alem

Could you share the workflow?

Regards

The UiPath Version is 2023.12.0
system dependencies I used before is 23.4.3 and I tried downgrade it to 23.4.3
still not working.
I even restart my laptop and still no go

I see,
Can you share the source code?
If it’s private, send it via message,
I will check for you
Regards,

Risk Rank Process.xaml (66.2 KB)

here’s the workflow.
thanks for your effort by the way

sure,
Risk Rank Process.xaml (66.2 KB)

1 Like

Hi @ibnu.alem ,
I can not open your project

But I create a test project with similar your argument and variable type
and I have any error similar you
I have checked packages
image
image
and json file
You can create new project again
Check Argument.zip (26.8 KB)

Or you can copy your step to my project
hope it help,

You got the same error?
so is it a bug?

Hi @ibnu.alem

I’m getting the same error when working in your project but when I created a new project and did the same assign activities it worked well. There might be issue with the project try creating a new project.

Regards

No,
I have any error with assign activity

My version of Studio and your are similar

Hope it help,

ok, thanks for confirm it