Invoke process will not end

From RPA1 I use Invoke Process to run RPA2 and when RPA2 is finished RPA1 continues. But from RPA3 to Invoke Process the same way as before to run RPA4, then when RPA4 is finished RPA3 just hangs and is not continued. I have no clue why RPA3 does not continue. Tried different settings but no luck.

Can you debug / add some log message after the “Invoke Process” to see if execution continues after that activity?


Try adding logs at start and end of each process and then check where it is hanging.then from there we can take forward


1 Like

I do not know how to do that because the execution does not continue after the Invoke Process. Could you be so kind and instruct me how to do it?



Do I use a log message activity and what log level do I use?


Yes use a log message and can set to info…

This way you will know where it is stuck depending on what log message we are getting


I put a log before and after the invoke process in RPA3, and in RPA4 at the end. The result is that the log RPA3 before invoke process is shown, the log in RPA4 is shown, but the last log after the invoke process in RPA3 is not shown.


So rpa3 last log message is also shown …and it did complete the process completely… may I know what activities are you performing there? In rpa4 if any after log and in rpa3 before the log message


No the last log in RPA3 is missing.

In RPA4 the log is the last activity - and it shows


So immediately after invoke you have a log and it is missing?

Can you show the porperties of incoke workflow please

Try checking isolated and check


Yes, immediatedly after invoke and Yes it is missing, and the RPA hangs.

There is no “isolated” that I can check

Can you try setting a value to “Timeout” in the activity settings to see if it makes a difference?

Timeout - Specifies the amount of time (in milliseconds) to wait for the activity to run before an error is thrown. Leaving this property empty waits for an infinite amount of time before throwing an exception. By default, this property field is empty.

Try to replace this with new Invoke activity see if that helps if not, can you elaborate more as what you are doing in that process.

Is it always stopping on RPA3 ?

Hi @raven

Verify that RPA4 is indeed completing successfully and not encountering any errors or exceptions. If there are issues within RPA4, it might not return control back to RPA3, causing it to hang. Check the logs or add logging activities within RPA4 to track its progress.



If you have run the process separately is each running properly?


If I set the timeout then the RPA hangs until the timeout runs out - this does not make any sense. What I need is that when RPA4 finishes then RPA3 continues.

If I disable the invoke process then both RPA3 and RPA4 runs without any problems.

I have tried to replace the invoke activity but no change. Yes the process always stops when the invoke process is finished in RPA4 and needs to return to RPA3 in order to continue.

RPA4 is indeed finishing succesfully - this was verified with the log that was at the end of RPA4.

Remember that I have the same setup with RPA1 and RPA2, and here I have no problem. So something in RPA3 or RPA4 is causing the problem but I have no clue what it could be because RPA3 runs the invoke process without problems and RPA4 finishes without problems, but then RPA3 stops/hangs and is never continued after the invoke process.

Hey raven,

Maybe one of your application that you are utilising in these processes they hang check task manager for this, how many instances of your application are running. Also
Can you verify logs from Event viewer at the time it hangs, for any errors there ?


Just to check can you run rpa3 which ever is handing from a different process and see if it still hangs


If I invoke RPA3 from another RPAtest then it runs normal. If I invoke RPA4 from another RPAtest then it hangs!

What I did was make a new clean RPAtest that invokes RPA4. Only activity was the invoke of RPA4. Does this mean that there is some error in RPA4? Remember that RPA4 by itself runs without problems and finishes.

I verified the Execution log (is this the log from event viewer?) and there is no error.

In task manager I only see RPA3 running, when RPA3 hangs, and I have to stop it manually.

Are you doing any force kill after these processes, some applications take time before they are ready to work again or some enterpirse application session keep hanging in task manager after force kill.

Could you check if thats the case