Improve activity display name

studio
i_considering

#1

For each activity used in code i need to change its display name so it would clearly show what is happening and its either takes alot of time or display names updates are skipped and code readability suffers. It would be alot more efficient if default values would include additional information for example:

  • For each => For each
  • InvokeWorkflowFile => Invoke
  • If => If
  • Assign => Assign
  • Build data table => Build data table

For complex situations (name too long) just short name could be left


#2

Can you explain a bit more what additional information you would need?

From your list, only InvokeWorkflowFile is different (altho no additional info), the rest are the same.


#3

Sorry, didn’t notice that when you include text between < and > it disappears

  • For each => For each “VariableName”
  • InvokeWorkflowFile => Invoke “fileName”
  • If => If “condition text”
  • Assign => Assign “variable name (left side)”
  • Build data table => Build data table “table name”

#4

I see what you mean. Sounds good; we already do this for some activities, we’ll just need to extend the functionality.
If you have other examples pls add them here.


#5

comment out=>Comment out "commented activity name"
Start process => start process “file name”