Image classification problems training pipeline

Hi, can anyone help me with this?. I’m trying to do the exercise from UiPath academy with Ai center using Image classification, but i have this error when I try to train the pipeline:

Train only of ImageClassification 4.0 launched - Run 613626a9-7964-4b4d-90dd-5d4e89ad2d79
Train only of ImageClassification 4.0 started - Run 613626a9-7964-4b4d-90dd-5d4e89ad2d79
Train only of ImageClassification 4.0 scheduled - Run 613626a9-7964-4b4d-90dd-5d4e89ad2d79
Train only of ImageClassification 4.0 failed - Run 613626a9-7964-4b4d-90dd-5d4e89ad2d79

Error Details : Pipeline failed due to ML Package Issue

2023-01-31 14:47:07,095 - uipath_core.trainer_run:main:74 - INFO: Starting training job…
2023-01-31 14:47:07,735 - matplotlib:_get_config_or_cache_dir:484 - WARNING: Matplotlib created a temporary config/cache directory at /tmp/matplotlib-gfiykdk1 because the default path (/home/aicenter/.config/matplotlib) is not a writable directory; it is highly recommended to set the MPLCONFIGDIR environment variable to a writable directory, in particular to speed up the import of Matplotlib and to better support multiprocessing.
2023-01-31 14:47:08,076 - matplotlib.font_manager:_load_fontmanager:1443 - INFO: generated new fontManager
2023-01-31 14:47:10,231 - - INFO: Dataset from bucket folder training-fa0025b6-48db-466b-8daa-00f1f6a22449/84782e2b-1e8c-4f29-900f-544282eaf298/289d04cc-85b3-436e-8098-41c7978487a1 with size 60 downloaded successfully
2023-01-31 14:47:10,232 - uipath_core.training_plugin:train_model:130 - INFO: Start model training…
2023-01-31 14:47:10,232 - uipath_core.training_plugin:initialize_model:124 - INFO: Start model initialization…
2023-01-31 14:47:10,271 - uipath_core.training_plugin:initialize_model:127 - INFO: Model initialized successfully
2023-01-31 14:47:10,272 - uipath_core.training_plugin:model_run:179 - ERROR: Training failed for pipeline type: TRAIN_ONLY, error: [Errno 2] No such file or directory: ‘/microservice/dataset/images’
2023-01-31 14:47:10,280 - uipath_core.trainer_run:main:91 - ERROR: Training Job failed, error: [Errno 2] No such file or directory: ‘/microservice/dataset/images’
Traceback (most recent call last):
File “/home/aicenter/.local/lib/python3.8/site-packages/uipath_core/”, line 86, in main
File “/microservice/”, line 57, in run
return self.training_plugin.model_run()
File “/home/aicenter/.local/lib/python3.8/site-packages/uipath_core/”, line 195, in model_run
raise ex
File “/home/aicenter/.local/lib/python3.8/site-packages/uipath_core/”, line 171, in model_run
File “/home/aicenter/.local/lib/python3.8/site-packages/uipath_core/”, line 255, in run_train_only
File “/home/aicenter/.local/lib/python3.8/site-packages/uipath_core/”, line 132, in train_model
response = self.model.train(directory)
File “/microservice/”, line 37, in train
File “/microservice/”, line 61, in process_data
self.df_train, self.df_test = preprocess.preprocess_data(self.opt)
File “”, line 11, in preprocess_data
File “”, line 31, in create_df_from_single_folder
FileNotFoundError: [Errno 2] No such file or directory: ‘/microservice/dataset/images’
2023-01-31 14:47:10,280 - uipath_core.trainer_run:main:98 - INFO: Job run stopped.

I have this structure for my dataset:
– <Training / Evaluation Directory>
– images
– Bus
– bus001.jpg
– bus002.jpg
– bus003.jpg
– Truck
– truck001.jpg
– truck012.png
– truck0030.jpeg
– Car

I already tried to create a new project but it didn’t work.
This is the way i am creating the pipeline:


Please select images folder as the input dataset not the training folder

This should solve the error


hello @Anil_G , I just tried what you recommend but it didn work. The status of the pipeline is still “failed” with the same error


Can you show the dataset picture once till the images folder

and does all the subfolders contain images?


Yes, all the folder have images. Here is an image that shows the path and some images in one of the folders:


Can you please confirm if you have created dataset in AI center?

and upload images there…ideally you have to upload there


I confirmed it.
Here is an image about dataset set up:


Isee the issue now…

So the input it needs is images folder and then subfolders

Create a training folder under datasets
then under training create images folder,currently you ahve it as Timages which is wrong
under that have your sub folders with images for cars bus etc

and in pipeline select the training dataset

Hope this helps


1 Like

Thank you very much, that was the error

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.