HTTP Request retrieving error with 501 status code

Hi guys,

I’m working on an automation which requires me to get information from a third party API.

I’ve build the request and used it for a while. It has been worked just fine most of the times, but sometimes, it gets me back the response 501.

To be more specific I’m getting this while trying to do the call from studio:

Cannot connect

The page cannot be displayed

Reason: The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties.
  • Click the Refresh button or try again later.
  • If you typed the page address in the Address bar, make sure that is spelled correctly.
  • If you are trying to reach a secure site, make sure your Security settings can support it.
Press Backspace or use the Browser's Back Button to return to the previous page.

The strange thing here is that the call works just fine from posman, retrieving the expected response.

Any ideas if this is UiPath related?


Hi @mircea.serban

Could you maybe re-share the screenshot?

Hi @loginerror. At the moment the call is working just fine.

And I don’t have any screenshots I just have that part that I’ve post. This was a log message wrote down in a text file.

1 Like

Hi @loginerror, I’ve encountered this again now.

Attached a print screen with the response from UiPath:

Could it be that the website would time you out for a bit? I know that it should then typically be the 429 response, but maybe this one handles it differently?

Are you by chance calling this websites a lot from your process?

I don’t think the website is timing me out as it is working for my colleagues which are on the same network and on the same VPN as me. Also, I’ve tried on another laptop with my account and it is working there.

I will try to delete all the data from uipath history.

One small idea would be that in case of a POST request with dynamic input, it could be that the body of the request is sometimes not just right.

For example, if you would use Slack API to send a message which takes JSON as the format of your POST call, and if some content of that JSON was based on some dynamic input, then if that dynamic content contains JSON-specific characters and you put them in without escaping them correctly, then the Slack API call would fail.

Just a shot in the dark here.