Http Request POST API Error

Hi,

I’m trying to send json data in http_request but not getting the desired output after sending the post API with json string in body.

I have tried following ways:
1)Read the Json file and output variable is created that will be passed to API Body
2)Body Format changed to application/json and accept format changed to JSON in these properties
3)Even deserialized the Json string so that to get the JObject variable and that will be passsed to API Body
4)Also tried using parse the json string and passed in body

still I’m not able to send the POST Request.
Please suggest a solution for this even after sending the data into correct way, still not getting the desired output.

Getting the error if I run POST api attaching the SS.


Lets assume the endpoint server is up and running

when not suceeding in the first rounds with the http request actvitiy often we can corsscheck e.g. with Postman / webbroweser addons. This allows us to RnD with an alternate and to explore more the restpoint.

Also it is recommended to the check the respoint api docu if it exists. On the first check it looks like the payload from post request is failing and not conform to what the API is expecting

Hi,
You can see in the postman I have checked it is giving expected result but not in http request uipath with same code.
I do not understand where am I missing in properties or something?

can you share with us more details on the request body? Thanks

Sure.
this file is the input to API
JsonData.json (40.7 KB)

Also attaching the properties tab of http request.
Thanks