How to use wildcard in select item activity


I am currently developing a process that searches for cars on a car sale website. The user inputs the make, and this value is used within a Select item to it pick out.

The drop-down contains a number of that specific model in the items, so the Select item isn’t able to pick up just the name. The numbers are constantly changing too, so I cannot write the number in.

Does anybody know how to include a wildcard in the Select item? I have tried
MakeFilter + "(" + "*" + ")" and MakeFilter + "(*)" but these have not produced an actual asterisk, not a wildcard.

Any feedback is appriciated

Hy @william.coulson,

Try the following:

  • Click on an item and check the selector
  • select the text you sish to change with your mouse, right click it and select ‘assign variable’
  • UiPath will figure it out on its own the selector.

Try it and let me know if ti worked, if so please like my answer and mark my answer as solution, it helps me.
Any questions please let me know

1 Like

Hey @William_Blech_Sister,

Here is the element and the selector for it

Where would I right click in this selector?

The selector is attached to a Select item, I am not using two Click activities as the drop-down items aren’t singular elements and can’t be individually indicated.

Edit: This is what happens when I try to indicate the item in the drop-down

If I understand it correctly, you want the select item Value to have a wildcard, not the selector for the dropdown box itself, is that correct?

For the select item activity to work, you have to specify the exact value from contained within the dropdown - you can’t supply a wildcard. However, an easy workaround is to use a different activity. Instead of the select item activity, you should use the Type Into activity (assuming you know the beginning portion of the value and not the middle/end only).

Just type however much you know and it will highlight that piece within the dropdown menu. End your type into with an enter key to select it. Make sure you’re using standard hardware automation and NOT SimulateType or SendWindowsMessages, which means this won’t work in the background.

So for example if you want it to select Audi, you would use a type into activity and type "audi[k(enter)]"

1 Like

Hey @Dave,

Thank you so much, this has worked!

Yes I was trying to get a wildcard in the value, I should’ve specified that.


I am clicking on the drop-down, then typing into it and using a hotkey to press enter.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.