How to Run a process in pip from orchestrator?

I have created a process and tried to run it via orchestrator. Although the process runs smoothly in pip but when I switch to running it manually, it throws an error:
Timeout reached.

at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Also when I run the process manually from the system, without pip then also it runs fine. The only issue comes when I try to execute it via orchestrator.
Not sure why this happens, but the same process while running via pip runs well. I need to know if there’s a way to run processes through orchestrator in pip form? Or is there something I am missing while configuring it up on orchestrator?

I am using an unattended bot for the same purpose.

Hi @spidey

I believe PiP was designed for Attended robots, but I might be wrong on that. Let me dig into it.

1 Like

Yep. PiP is only for attended robots hence processes can be started in PiP only from UiPath Assistant

1 Like