How to read .xlsm file in Uipath

Hi All,

Iam getting error reading .xlsm file. I have used excel application scope. Can any one help me.

Job stopped with an unexpected exit code: 0xE0434352

Hi @Thunga_Hima

Ensure that the .xlsm file you are trying to read is accessible and not open in any other application. If the file is open in Excel or any other program, close it and retry the workflow. Confirm that Microsoft Excel is installed on the machine running the UiPath robot. If Excel is not installed, you won’t be able to use the Excel activities. Install Excel and try running the workflow again.


The error code 0xE0434352 indicates a .NET Framework exception. This error can occur for various reasons, including issues with the .xlsm file, Excel application, or the environment setup. Here are a few steps you can follow to troubleshoot and resolve the issue:

  1. Verify the file path: Ensure that the file path provided in the Excel Application Scope activity is correct. Double-check the file extension and ensure that the file exists at the specified location.
  2. Check file permissions: Make sure that the account running the process has appropriate permissions to access and modify the .xlsm file. If necessary, adjust the file permissions to allow the robot account to read and write the file.
  3. Restart Excel: Close any open instances of Excel and restart the application. Sometimes, Excel processes can become unresponsive or encounter conflicts that can cause issues while reading .xlsm files.
  4. Check for Excel add-ins: Disable any Excel add-ins that might interfere with the automation process. Some add-ins can cause conflicts or introduce unexpected behavior while interacting with Excel files.
  5. Update UiPath.Excel.Activities package: Ensure that you have the latest version of the UiPath.Excel.Activities package installed in your project. Updating the package to the latest version can help resolve compatibility issues and provide bug fixes.
  6. Try different file formats: If the issue persists, try saving the .xlsm file as a different format (e.g., .xlsx) and see if the robot can successfully read the file. This can help determine if the issue is specific to the .xlsm format or if it’s a more general problem with Excel.
  7. Check event logs: Review the event logs on the machine where the process is running for any additional error details or relevant information that could shed light on the issue.

You should at least try to not make it look like chatGPT was used lol

1 Like

Hi @Thunga_Hima

Both Excel Application scope in classic version and Excel Process Scope → Use Excel File accepts .xlsm files. If you are still not able to sort it out try deleting and re initializing the activity. Hope you give the correct path of the .xlsm file. Hope it helps!!


Hi @Thunga_Hima

Can you delete all excel processes from task Manager first and then run your workflow and if still doesn’t work may be the file is corrupted copy the same file information in another excel and then run and see if you are still receiving the error.

Hope it helps!!