How to modify selector correctly

datatable
excel
selector
sap
web

#1

Hi all,

Issue with the selector.

I’m trying to enter data in a SAP NetWeaver Business Client web based timesheet in grid form.
robot is reading a excel file puts it in a datatable and with a for each iterates through. since the selector for the first input field is changing (at least weekly) and there is no fixed part of the selector, the attach to live element doesn`t work. Plus since I tried it, it totally screwed up my whole workflow and even my whole OS. I’ve attached my sequence where the robot is supposed to type into and on the other png files highlighted where it should type (white field below Eng. ID) and where it is trying to type after I said attach to live element. small grey area on the left side.

When I had my first go, before the attach to live element and before the week changed it was working correctly. I tried anchor base, but it doesn’t find the field as well to type into, and again messes up the whole workflow. I’ve already started 2 new projects with a little bit different aproaches and it keeps screwing up. Once it happens there is no going back to get it working properly. I have read dozens of forum posts here, watched videos over and over again, and can´t find the wright answer.

Also attached the ui explorer tree.

thank you for your time

cheers

highlight

Time Input.xaml (21.1 KB)
selector


#2

Hi @dominik.breer,

In Tag INPUT IDX value
Idx='*' ->bot not able to identify if multiple selector founds

So Try to give IDX value , so bot can able to find the correct selector.

Regards,
Arivu


#3

Hi @dominik.breer,
The selector you are using doesn’t have enough information to know which field you are trying to fill.
I saw in your ui explorer tree that you have the tableCol and tableRow attributes. Try to use them, they should be unique.

Hope this helps,
Magali


#4

Hi @Magali_Philippe,

thanks for the quick answer,

the selector as you see works totally fine.

I’m trying to get rid of the <htmlwindowname=154545 cause this is changing every week as well as the
<webctrl id=WD
so after this is changing it can’t identify the field anymore and is typing all over the place. even in the url

I would try to leave the <html title and <webctrl tag attribut


#5

thank you @arivu96 . believe me I tried

this is the message I get when I replace it with a *

idx


#6

Hi @dominik.breer,

i told give IDX value instead of *.

Regards,
Arivu


#7

@arivu96

sorry my bad,

but the value will change weekly. so I can’t rely on this. cause it will not be identified next time


#8

Hi @dominik.breer,

ok i got it.

Try to Add Main Parent selector also.
use * if its changing dynamically.

Regards,
Arivu


#9

Hi @dominik.breer have you found a possible solution for the inconvenient? I try to automate a similar robot but I have the same issue, just need a method to move to the second line and match this with the For Each Row activity.

Regards.
vjara


#10

Hi @vjarapy
actually I´ve performed a click action and modiified the selector so it kinda works. Then the only possible solution that works for me so far is is sending hot keys (tab, enter) and at the last one a double tab key, to jump to the next line, Any other attempts failed.