Governance Enforcement File - Breaking Orchestrator Publishing

After upgrading to 2021.10.5 our standard governance file enforcing analyzer rules is breaking the ability of developers to publish projects to Orchestrator as a default option. Removing the governance enforcement enables the option to publish to Orchestrator and when enforced this options is no longer available. Anyone seen or have a fix for this? I have tried updating the governance file for the custom feeds but this is not a custom feed, rather the default orchestrator feed!

Enforced Governance File:

Disabled Governance:

@Robert_Schneider how do you enforce the file? Is it done via AO or by placing the gov file in the indicated directory?

Can you please share the file with us? I could not replicate the issue on our side and would like to understand what is the rootcause.

Sorry I have not yet responded. Here are the details.

Orchestrator on premise version 21.10.2
Studio version 21.10.5

Enforcement via Orchestrator asset (attempted both via file path and raw text in the asset) ref:

Any governance file is causing this issue, even newly created ones from studio.

As a work around I have been able to enforce via local file instead. Ref: Governance

This is not ideal as any changes or new machines require action to apply the governance enforcement file. Governance

@Robert_Schneider we tried to replicate the issue together with the dev team but with no success. Do you think you can join a zoom so you can screen share the issue?

Please DM some available time slots if you can.


I am engaged with UiPath premium support and have shared this behavior three times. We did upgrade our platform and did not complete a fresh install. Wondering if the upgrade path could be the issue?

2020.10 → 2021.10.2

Ticket number: 01485496

The support representative took a video of the issue.

This is now a known reported bug. Awaiting an update from UiPath on when this will be resolved and which release. I will update once I have more information.

It’s official UiPath stopped supporting a previously supported component for Classic Folders during their LTS life cycle. Reference:

This approach to remove a feature during LTS due to inadequate testing during the upgrade timeframe is very disappointing and not my previous experience received from UiPath. Here’s to hoping this behavior doesn’t continue as it creates a large risk for my organization UiPath would remove supported features during their LTS life cycle.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.