Google spreadsheets API doesn't grant me access while the other Gsuite applications work

Hello everyone,

I have a problem with the Google spreadsheet API.

I did correctly the procedure to create the Google API because, if I want to use Gmail or Calendar, it works without issues.

However, if I insert in the sequence some activities from Google spreadsheets, when I try to access my account it pops us the message:
“The app was blocked. This app tried to access sensible information on your Google account.”

I already activated on Google API libraries both Drive and Spreadsheets API.

Any ideas on how to proceed?

Thank you so much in advance!

Greetings @Alex_Lanaro , Welcome to UiPath community!


Can you try checking only the spreadsheet here? Also you can check to see if two steps verification is active for you google account or not. If activated you might try deactivating it and give a test run.


Holy moly @AKM_Robinuzzaman , thank you very much.

I spent 8 hours trying to solve this problem, it never occured to me to try out this method.

The only problem now is that, if I try to activate something other than the spreadsheets, like the gmail one, it gives me the same error.

Any thoughts on how to proceede? Thank you very much in advance.

Greetings from Italy!

@Alex_Lanaro for that you might wanna try the second option. I have not faced any issue like that. So cant be sure for this one mate.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.