Google Sendmail attachment errors with BC36574

Using google workspace send email. When I try to assign an attachment which is saved in a string variable, I get “BC36574 string cannot be converted to IEnumerable(Of IResource) because ‘char’ is not derived from IResource”. Sceenshot below shows errors and package versions. Not sure how to get around this, everything I try is a bust.

Hi @Jallum ,

Its because that field expects array/list/enumerable value to be passed.

Can you try passing {fname} there?


Thanks for the quick response! I had tried that already. I should have mentioned it in the origial post. Sorry.

@Jallum , same issue is encountered in the following thread, take a look:


Morning. I read the post and yes, it’s the same situation, but it still didn’t solve it in this case. I’m ready to open a ticket with UiPath support.

1 Like

@Jallum ,

You can do workaround for it as explained in this thread:


It worked! Thank you very much for your help. I appreciate the time and effort you took to search this out.
I was ready to just give up.

1 Like

Glad that i could help .

Cheers @Jallum

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.