Google blocks the Gsuite access, How to solve

Dear members,

I am trying to download a file from google drive using gsuite activities.
But when i run bot, gsuite access is blocked.

Can anyone help ?

Regards,
Sahil Garg

1 Like

Hi @Sahil_Garg1!

I already faced similar obstacle, what type of authentication are you using on gsuite scope?

Hi,

I am using,
API key, Client ID and client secret

Hi,
Can you help. Please if you know solution

You just should use only one @Sahil_Garg1!

Try one of them and run again, if doesn’t work, make them sure you tried all authentications, if stills not work, tell here :))

1 Like

Hi,

I tried with only client id and secret but still same error.

Can you try the other authentications one by one too?

@Sahil_Garg1 - This is my setup and i just ran and got the output…

Hi,

Can you pleasee tell what kind to application you are selecting while created client id

image

Hi,

Am not sure where i am making mistake, but getting app block again

I am also facing same issue…Do you get any solution for it? If yes please explain

Hi shibina,

Actually i was doing mistake in credentials input and permission for drive api . Just check ur credentials and permissions which u had given in Gsuite Scope.

Hi,
I was having the same issue. I was trying to access Google Sheets.
The issue was solved after i created new project, in this project i created credentials specifically for Google Sheets, in OAuth consent screen settings, in Scopes section, I added ./auth/spreadsheets and ./auth/spreadsheets.readonly. Also in UIPath in the menu Configure OAuth2 scopes I left only ./auth/spreadsheets. For some reason ./auth/spreadsheets.readonly was not working.
I hope this story helps you. looks like one can make a lot of mistakes and the system won’t tell you what is wrong.

2 Likes

Hello, try checking the https://www.googleapis.com/auth/drive oauthscope. It has full permission for every access. Then uncheck the other scopes.

5 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.