Gmail issue

Hi Team
i got an following error !!!

Main has thrown an exception

Source: Get POP3 Mail Messages

Message: Authentication failed.

Exception Type: AuthenticationException

MailKit.Security.AuthenticationException: Authentication failed.
at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

can any one clarify where i’m gone wrong

Edit: removed attachment for time being.

Have you enabled the pop3 settings in your email?
If not, kindly use this link and follow the instructions.
https://support.google.com/mail/answer/7104828?hl=en

And yes, you may receive one email to allow that authentication from third party applications whenever you are trying to run your workflow.

Thanks,
Jiban

Hi @chintu,

Please check your workflow, as you should not disclose your credentials in public.

Hope you will understand the risk.

Thanks,
Jiban

1 Like

Hi @jibanjyoti
just for the testing purpose the i gave credential directly !!!

next time i wont do that mismatch

Hi @jibanjyoti
After enabling the pop up same issue occurs
do i need to configure anything else ?
do i need to configure gmail application in my system ?

Hi @chintu,

Please go through the following link.

Make sure you have completed all the steps listed in this link.

Thanks,
Jiban

2 Likes

Hi All,

I am new to this community and also do no tknow how to search topic and post question there. Actually when i am running my program getting attached error regarding IMAP mail message i have used port number 993 and 143 and also the firewall setting as off.

Please help i shall be highly obeliged.
My email ID is: nitin.ipec07@gmail.com

Hi,

please check Gmail Sign-in & Security --> Apps with account access --> Allow less secure apps : ON
try to change settings from desktop (avoid changes from Andriod App)

Thanks,
Snehal

1 Like

Hi @jibanjyoti,

Thanks for this link, I tried to use it, unfortunately after to log in I have the following message: “The setting you are looking for is not available for your account.”.

So is there any other solution?

Thanks,

Miguel