Github UIPath App not working

Hi all, I am attempting to push my local repo over https to github . While authenticating with " Sign in with GitHub , I was informed via both to get the Github UIPath app. However, I get an error message when I go to the URL provided. Do let me know if there is an alternate workaround for this, thank you!


Hi @EchoS

Just now I tried this URL Sign in to GitHub · GitHub

and its working.

Can you try with different credentials if you are already logged in in your browser please logout and login and make sure you have the necessary edit/write access on the git

This is the minimum permission set



Hi Anil,

Thanks for the reply. I’ve tried the log-in log-out, on my normal browser as well as incognito and I still receive the error message “The page is taking too long to load”.

No issues with my internet as far as I know.

For the edit/write access on git, may I know which page I should go to in order to review it?

Not sure if you are referring to the steps here: Editing a GitHub App's permissions - GitHub Docs

I do not have the app viewable so I am not able to edit any permissions based on the steps from the link.


Hi @EchoS

are you on any firewall?. Just to check can you try this as see if you are able to access this? GitHub Apps - UiPath · GitHub

And also on GIT search for install unknown apps in settings and enable it.

If its a managed GIT by any admin, ask them to give the permissions for installing unknown apps

If you find this of any use


Hey Anil,

Managed to identify the issue. As per Github Support, outside collaborators in orgs with many repositories would face this issue. After I removed myself as a collaborator, I was able to access the app normally.

Thank you for your time!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.