Getting below "Assembly Reference Error", Unable to find the package of "Microsoft.Office.Interop.Excel"

Hi,

I have developed a code in 2019 community UiPath Studio which has excel related VB.Net code in invoke code activity. Now, Studio version is upgraded to 2021 and getting “Assembly Reference Error”, Unable to find the package of “Microsoft.Office.Interop.Excel”.

I had same issue with 2019 community version also, but it was resolved by importing “Microsoft.Office.Interop.Excel” in the Import tab and installed the same in the manage package. But when I’m trying to install the package, its not available now. Kindly help me with the issue. Please find below ss for reference.

Thanks in advance!
Prasad

Have you tested to add the package source https://api.nuget.org/v3/index.json ?

Hi. I downloaded the index.json file and added it in the user defined package source. But I’m still getting the same error. Could you please elaborate the solution?

Thanks!

You shouldn’t download the json file. You need to add the URL.

After adding the URL, you should be able to find the package:

It worked. Thank You for your quick response and help on this!

1 Like