Get Text. Large string scrapping from legacy desktop application

I’m having trouble extracting a large string which is inside editatable text box from a desktop application using UiPath. The string is xml type. The string consists of more than 8000 characters with 4000 spaces and 160 lines in it, and UiPath is only able to extract around 4000 character with 1800 spaces and 90 lines of the string. I’ve tried increasing the timeout value, but that didn’t help. I’m using the activities provided by UiPath to extract the text, but they don’t seem to work for large strings. Can anyone suggest a solution to this issue?

Hi! Welcome to community!

Did you try with Screen scraping?

Once try with screen scraping. and select Full Text.



No it didn’t work. As my project was in modern design activities I changed it to classic and try to use screen scrapping - Data scrapping. Actually it didn’t even identify the element too as it pop up the error message like please select the valid table cell.

Actually I am using AA Ui Framework in most of the case to automate desktop application.
It doesn’t work form me. Is there is any other ways to solve it.

You can copy the test in clipboard and then insert it into the text file for further manipulation!

I am doing the same. Ctrl + A and clipboard activity. But is there any way to get full text of editable text box without using hot keys. Get Text working fine but incomplete text is there is any issue with size of variable in UiPath. @UiPath_Community

Have you tried with other methods in modern activities for get text?

Yes I have tried these all method non of them worked. Actually I have copies all the text from desktop application to notepad and retry if it was variable size issue. In that case, Scrapping method (default) has exactly extract same number of character which I am already able to extract in main application. And after doing FullText in Notepad and doing get text with Scrapping method(fulltext) it was successfully extract all the characters. Hoping same in my main application but it didn’t work and only able to extract partially even doing full text in main application.

It’s not UiPath - the string limit is way above 4000 characters. It must be some limitation in the Get Text activity. You could try the Get Full Text and Get Attribute activities. Maybe you’ll get lucky and one of them won’t have this limitation.

It didn’t work.
Actually when I open Ui Explorer and watch attribute of target element i.,e editable textbox. It also shows the partial text only. But when I do ctrl+A and ctrl+C and clipboard activity for changing it string then only works. Also when I scroll it down in textbox area all the text can be seen clearly. Please suggest me any other idea if you know.
Thank you

@UiPath_Community Any update on this?