Get Python Object: Error converting Python object - String result

Edit1 I removed the normal returned results and I just replaced it with “1” and that worked in UiPath. I think there is a mismatch between what Python is returning and what Uipath Get Python Object TypeArgument is.

Edit 2 So I discovered that the string returned might be too big which is causing issues. The reason that I say this is that I sliced the returned string to bring back only the first 100 characters and that worked perfectly fine in UiPath. Is there a way to assign a large string or would that be another variable type?

I currently have a python script that returns a result in a form of a string. I even checked the returned variable type and it says it is string.

I can load the script, I can invoke the method but the minute that I try to get the Python Object , I get the following error with no real indication on what is going on. Has anyone encountered this before?

"Get Python Object: Error converting Python object"