Get OCR Text and Get Text difference working differently

Hi, I’m developing a clicker bot using a desktop app (WeChat) that has very little UI information (emphasis on VERY). Here’s a screenshot of the app page :

The original method I used was using the Get Text activity. I OCR the whole app screen to extract all text (which works), I write it to a .txt and run it through a code to extract only the relevant bits. I then iterate through each line and input it into a dynamic selector in the Click activity to click on the articles, once it has clicked on every article it scrolls down, detects if it’s at the end. Rinse and repeat. No problems, I accounted for every false positive that it reached the end, very thorough workflow. That’s not the issue though.
The problem is if it scrolls too far down (about 1000 articles later) Get Text activity doesn’t work anymore. It’s not able to get text (because it takes into account all the hiddent text and there’s some sort of memory capacity? I tried all scraping methods including native, full text and ignoring hidden text, default, etc - Screenshot, you can see the cursor is all the way down), still doesn’t work clicked on refresh and everything.

So I tried switching to Get OCR Text activity using the Google Vision OCR, and it solved the problem. It’s able to extract and process text from 1000 articles down easily.

But the problem is for some reason when I run the extracted text to my dynamic selector it doesn’t work anymore? I printed the strings to confirm it extracted properly, converted it ToString, I tried everything.
Even if I manually input a string to click or highlight it doesn’t work. And if i switch back to previous (Get Text activity) method it works perfectly again.

Does anyone have any insight into why these problems occur? Any help would be greatly appreciated thanks.

1 Like

Hello @Test11 Just a thought, Did you tried using Data Scrapping or Table Extractor in the Explorer. Or it is also posing the same issue.


Did you try to indicate each item separately use idx to iterate over each and get text only for that particular one?

that way the text you get also get limited and it can extract only one piece at one time


Hi Shantanu,

I’m pretty sure Data scraping and Table Extractor only work for web applications. I am using a desktop app.

Hi, the problem is not extracting text, it’s able to successfully extract all the text that I want. The problem is the “reverse” of this.
If I’m able to recognise and extract text why can’t I recognise and click on it?


May be the casing or spacing is changing…or some special characters are added…that makes a huge difference…also adding of new line etc will not let the selector recognize the element …get ocr might be adding any of these extra…even a small space would scramble