Get Form Tasks not retrieving existing Task IDs

I am using Get Form Tasks to get list of Task Ids present in the Action center as shown in screenshot below. But this is bringing probably some older deleted tasks, instead of the current pending and completed tasks. Suggest how can this be corrected.



Output shows

Retrieved 0 tasks from server. Complete url: UiPath in %28%27Pending%27%2C %27Unassigned%27%29%29 and %28Type eq %27FormTask%27%29&$select=Id%2CStatus%2CPriority&$top=100

When I tried to open this URL, it shows below message

{“message”:“You are not authenticated!”,“errorCode”:0,“result”:null,“targetUrl”:null,“success”:false,“error”:{“code”:0,“message”:“You are not authenticated!”,“details”:“You should be authenticated (sign in) in order to perform this operation.”,“validationErrors”:null},“unAuthorizedRequest”:true,“__abp”:true}

Even if I am using partial url till UiPath, I am getting same above message

So, it looks like some permission issue to access tasks, can anyone suggest where and what rights should be configured in Orchestrator.


I would suggest you to add Filters in the filter property example:Status in ('Pending', 'Unassigned'). Please refer the below document for your reference

Already tried it with just Completed, just Pending and with above that you suggested, but that brings zero records.

Can you try “Status eq ‘Completed’” in filter property

If issue still persists , Please refer this thread Get form task returning empty - #6 by Anil_G